Version 1.2.0 of Struts2 Bootstrap Plugin released

Since the First 1.0.0 Release of Struts2 Bootstrap Plugin there are some important changes.

Maven Support

Like promised in my previous post, this Plugin is now available as Maven Artifact.
<dependencies>
    ...
    <dependency>
        <groupId>com.jgeppert.struts2.bootstrap</groupId>
        <artifactId>struts2-bootstrap-plugin</artifactId>
        <version>1.2.0</version>
    </dependency>
    ...
</dependencies>

Extended Showcase

The Showcase includes now more Examples.
  • Example for Vertical Form Layout
  • Example for Inline Form Layout
  • Form Elements with Help Text
  • Textfields with prepended text or appended text
  • An AJAX Example in combination with the Struts jQuery Plugin
Currently only the the SNAPSHOT Version 3.3.0 of Struts2 jQuery Plugin is supported, because Bootstrap requires jquery version 1.7.1 as minimum.

Download: http://code.google.com/p/struts2-bootstrap/downloads/list
Showcase: http://struts.jgeppert.com/struts2-bootstrap-showcase/
Issues: http://code.google.com/p/struts2-bootstrap/issues/list

6 Kommentare

  1. Rickard

    Very nice, thank you! Looking forward to a stable 3.3.0 version of jQuery Plugin. Keep up the good work!

    Antworten
    1. jogep (Beitrag Autor)

      Thank you for the compliment. Struts2 jQuery Plugin in Version 3.3.0 is coming soon.

      Antworten
  2. Mugil

    Dear Johannes Geppert,

    Great job… But I have problem with using jquery plugin with bootstrap plugin.

    Error reading included file template/jquery/controlheader.ftl
    The problematic instruction:
    ———-
    ==> include “/${parameters.templateDir}/${parameters.theme}/controlheader.ftl” [on line 21, column 1 in template/bootstrap/text.ftl]
    in include “/${parameters.templateDir}/${parameters.parentTheme}/text.ftl” [on line 67, column 17 in template/jquery/datepicker.ftl]
    ———-

    I have used your lib files of bootstrap showcase.

    Regards,
    Mugil

    Antworten
    1. jogep (Beitrag Autor)
  3. James Soper

    Any easy way to do modals with this plugin?

    Antworten
  4. jogep (Beitrag Autor)

    Currently Javascript Tags like the jQuery Tags are not part of this Project. The Focus is on the form element templates.

    But of course you are free to use the Bootstrap functions like described here.
    http://twitter.github.com/bootstrap/javascript.html#modals

    Anyway patches are Welcome. :-)

    Antworten

Kommentar verfassen